Saturday, November 18, 2006

Memisahkan gateway traffic Local dan International

Teknik lainnya utk memisahkan traffic data local/IIX dan International adalah dengan menggunakan mark-routing

Misal untuk traffic International dilewatkan melalui gateway 203.89.24.65 sedangkan traffic local Indonesia di lewatkan melalui gateway 203.89.24.177.

Image 

contoh konfigurasi IP address router user pada interface yang terhubung ke router Datautama 

/ ip address
add address=203.89.24.66/27 network=203.89.24.64 broadcast=203.89.24.95 \
    interface=ether1 comment="ip point to point utk traffic lnternational" \
    disabled=no
add address=203.89.24.178/30 network=203.89.24.176 broadcast=203.89.24.179 \
    interface=ether1 comment="ip point to point utk traffic local" disabled=no
 

Pertama masukkan daftar ip blok dari router NICE ke /ip firewall address-list seperti berikut:

/ ip firewall address-list
add list=nice address=58.65.240.0/23 comment="" disabled=no
add list=nice address=58.65.242.0/23 comment="" disabled=no
add list=nice address=58.65.244.0/23 comment="" disabled=no
add list=nice address=58.65.246.0/23 comment="" disabled=no
add list=nice address=58.145.174.0/24 comment="" disabled=no
add list=nice address=58.147.184.0/24 comment="" disabled=no
add list=nice address=58.147.185.0/24 comment="" disabled=no
dst…


untuk mendapatkan script diatas dapat melalui URL berikut:

http://www.datautama.net.id/harijanto/mikrotik/ip_firewall_address_list_nice.php

Kemudian tandai packet data yang menuju local Indonesia

/ ip firewall mangle
add chain=postrouting dst-address-list=nice action=mark-routing \
    new-routing-mark=nice passthrough=yes comment="" disabled=no

Selanjutnya buat ip route berikut 

/ ip route
add dst-address=0.0.0.0/0 gateway=203.89.24.65 scope=255 target-scope=10 \
    comment="traffic selain local Indonesia" disabled=no
add dst-address=0.0.0.0/0 gateway=203.89.24.177 scope=255 target-scope=10 \
    routing-mark=nice comment="traffic local Indonesia" disabled=no

 

Dengan demikian maka jika ke jaringan local Indonesia akan melalui 203.89.24.177 sedangkan untuk ke International melalui 203.89.24.65, sehingga jika interfacenya dipisah diantara router user dengan router datautama dapat diberi dua mikrotik sebagai bridge utk melimit traffic International maupun local secara terpisah.

 

Hasil traceroute ke www.plasa.com

C:\Documents and Settings\user>tracert www.plasa.com

Tracing route to www.plasa.com [202.134.0.12]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  192.168.2.1
  2    <1 ms    <1 ms    <1 ms  ip-24-177.datautama.net.id [203.89.24.177]
  3    16 ms    25 ms    12 ms  ip-24-1.datautama.net.id [203.89.24.1]
  4    25 ms    25 ms    15 ms  telkomnet.openixp.net [218.100.27.179]
  5    21 ms    23 ms    19 ms  202.134.2.148
  6    12 ms     9 ms    12 ms  web.plasa.com [202.134.0.12]
  7    10 ms    12 ms    28 ms  web.plasa.com [202.134.0.12]
  8    11 ms    17 ms    12 ms  web.plasa.com [202.134.0.12]

Trace complete.

Hasil traceroute ke www.yahoo.com 

C:\Documents and Settings\user>tracert www.yahoo.com

Tracing route to www.yahoo-ht2.akadns.net [209.131.36.158]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  192.168.2.1
  2    <1 ms    <1 ms    <1 ms  ip-24-65.datautama.net.id [203.89.24.65]
  3    15 ms    25 ms    10 ms  ip-24-1.datautama.net.id [203.89.24.1]
  4    12 ms    12 ms    15 ms  202.59.203.241
  5    10 ms    14 ms    10 ms  202.153.90.89
  6    94 ms    99 ms    71 ms  202.153.90.225
  7   110 ms   204 ms   225 ms  208.30.197.53
  8     *      140 ms   125 ms  sl-bb20-hk-14-0.sprintlink.net [203.222.38.37]
  9     *      163 ms   161 ms  sl-bb20-tok-15-0.sprintlink.net [203.222.33.88]

 10   318 ms   245 ms   241 ms  sl-bb21-sea-8-2.sprintlink.net [144.232.20.50]
 11   305 ms   260 ms   222 ms  sl-bb20-sea-15-0.sprintlink.net [144.232.6.89]
 12   218 ms   216 ms   228 ms  so-3-0-0.gar1.Seattle1.Level3.net [209.0.227.133
]
 13   226 ms   225 ms   313 ms  ae-1-53.mp1.Seattle1.Level3.net [4.68.105.65]
 14   237 ms   232 ms   239 ms  as-0-0.bbr2.SanJose1.Level3.net [64.159.0.218]
 15   230 ms   235 ms   238 ms  ae-23-54.car3.SanJose1.Level3.net [4.68.123.109]

 16   232 ms   241 ms   365 ms  4.71.112.14
 17   230 ms   238 ms   233 ms  g-1-0-0-p171.msr2.sp1.yahoo.com [216.115.107.87]

 18   345 ms   314 ms   258 ms  UNKNOWN-209-131-32-23.yahoo.com [209.131.32.23]

 19   311 ms   261 ms   235 ms  f1.www.vip.sp1.yahoo.com [209.131.36.158]

Trace complete.
 

 

Sedangkan disisi cisco router datautama dapat diseting seperti berikut:

 

 

interface FastEthernet0/1

 description Interface yang point to point dengan International

ip policy route-map from-int-to-user

 duplex auto

 speed auto

!

interface FastEthernet1/1

 description Interface yang point to point dengan IDC 

ip policy route-map from-nice-to-user

 duplex auto

 speed auto

 

!

 

access-list 120 remark traffic dari luar ke user

access-list 120 permit ip any 203.89.26.0 0.0.0.255

route-map from-nice-to-user permit 10

 match ip address 120

 set ip next-hop 203.89.24.178

!

route-map from-int-to-user permit 10

 match ip address 120

 set ip next-hop 203.89.24.66

 

Jika ingin lebih baik maka di sisi user harus menggunakan router bgp, utk memisahkan traffic user menggunakan BGP akan dijabarkan pada artikel berikutnya.

 

Selamat mencoba. 

Memisahkan Bandwidth Lokal dan International menggunakan Mikrotik

Versi 3

Perubahan dari versi sebelumnya:

  1. Proses mangle berdasarkan address-list
  2. Pemisahan traffic Indonesia dan overseas lebih akurat


Semakin berkembangnya konten Internet lokal di Indonesia telah memberikan peluang bisnis baru dalam industri Internet di Indonesia. Saat ini banyak Internet Service Provider
(ISP) yang menawarkan paket bandwidth lokal atau IIX yang lebih besar dibandingkan bandwidth Internet Internasional, hal ini seiring dengan semakin banyaknya pengelola RT-RW Net yang mampu menyediakan layanan koneksi Internet yang lebih terjangkau bagi lingkungan sekitarnya.

 

Permasalahan umum yang terjadi pada jaringan RT-RW Net adalah masalah pengaturan bandwidth. Pada umumnya pengelola RT-RW Net akan kesulitan pada saat ingin memisahkan antara traffic lokal dengan traffic internasional karena umumnya jaringan RT-RW Net hanya menggunakan static routing, berbeda dengan ISP yang mampu membangun jaringan yang lebih komplek menggunakan protocol routing BGP sehingga ISP dapat dengan mudah memisahkan antara traffic local dan internasional.

 

Untuk memisahkan traffic lokal dengan traffic internasional tersebut RT-RW Net dapat dengan mudah menggunakan PC Router + Sistem Operasi Mikrotik, Mikrotik sebenarnya adalah linux yang sudah di buat sedemikian rupa oleh pengembangnya sehingga sangat mudah diinstall dan di konfigur dengan banyak sekali fitur dan fungsi. Untuk lebih lanjut mengenai mikrotik dapat dilihat pada situs webnya http://www.mikrotik.com atau http://www.mikrotik.co.id

 

Berikut adalah sekenario jaringan dengan Mikrotik sebagai router

Image 

Gambar 1. Sekenario Jaringan

 

Penjelasan:

  1. Mikrotik Router dengan 2 Network Interface Card (NIC) Ether1 dan Ether3, dimana Ether1 adalah Ethernet yang terhubung langsung ke ISP dan Ether3 adalah Ethernet yang terhubung langsung dengan jaringan 192.168.2.0/24
  2. Bandwidth dari ISP misalnya 256Kbps internasional dan 1024Kbps lokal IIX
  3. Komputer 192.168.2.4 akan diberi alokasi bandwidth 128Kbps internasional dan 256Kbps lokal IIX

 

Untuk memisahkan antara traffic lokal IIX dengan traffic internasional caranya adalah dengan menandai paket data yang menuju atau berasal dari jaringan lokal IIX menggunakan mangle. Pertanyaannya bagaimana caranya Mikrotik bisa mengetahui paket tersebut menuju atau berasal dari jairngan lokal IIX?

Jawabannya adalah dengan mengambil data dari http://lg.mohonmaaf.com

Pilih Query dengan men-cek-list BGP dan klik Submit

Image 

Gambar 2. Hasil Query http://lg.mohonmaaf.com untuk perintah “show ip bgp”

 

Fungsi dari http://lg.mohonmaaf.com adalah sebagai fasilitas looking glass jaringan lokal yang dikelola oleh PT. IDC , terima kasih kepada Bapak Johar Alam yang telah menyediakan layanan tersebut.

Dari hasil query tersebut selanjutnya simpan sebagai text files untuk selanjutnya dapat diolah dengan menggunakan spreadsheet contohnya Ms. Excel untuk mendapatkan semua alamat Network yang diadvertise oleh router-router BGP ISP lokal Indonesia pada BGP router IDC atau National Inter Connection Exchange (NICE).

Pada penjelasan versi-2 dokumen ini saya menggunakan teknik langsung memasukkan daftar ip blok ke /ip firewall mangle, dengan teknik ini saya harus memasukkan dua kali daftar ip yang didapat dari router NICE ke /ip firewall mangle.

Cara lain yang lebih baik adalah dengan memasukkan daftar ip blok dari router NICE ke /ip firewall address-list dengan demikian maka pada /ip firewall mangle hanya terdapat beberapa baris saja dan pemisahan traffic Indonesia dan overseas dapat lebih akurat karena mangle dapat dilakukan berdasarkan address-list saja.

Lebih jelasnya adalah sbb:

Selanjutnya buat script berikut untuk dapat diimport oleh router Mikrotik

/ ip firewall address-list
add list=nice address=58.65.240.0/23 comment="" disabled=no
add list=nice address=58.65.242.0/23 comment="" disabled=no
add list=nice address=58.65.244.0/23 comment="" disabled=no
add list=nice address=58.65.246.0/23 comment="" disabled=no
add list=nice address=58.145.174.0/24 comment="" disabled=no
add list=nice address=58.147.184.0/24 comment="" disabled=no
add list=nice address=58.147.185.0/24 comment="" disabled=no
dst…


untuk mendapatkan script diatas dapat melalui URL berikut:

http://www.datautama.net.id/harijanto/mikrotik/ip_firewall_address_list_nice.php

URL diatas secara online akan melakukan query ke router NICE dari http://lg.mohonmaaf.com

dari hasil URL diatas copy lalu paste ke mikrotik dengan menggunakan aplikasi putty.exe ssh ke ipmikrotik tersebut, caranya setelah di copy teks hasil proses URL diatas lalu klik kanan mouse pada jendela ssh putty yang sedang meremote mikrotik tersebut. Cara ini agak kurang praktis tetapi karena jika script diatas dijadikan .rsc ternyata akan bermasalah karena ada beberapa baris ip blok yang saling overlap sebagai contoh:

\... add address=222.124.64.0/23 list="nice"
[datautama@router-01-jkt] > /ip firewall address-list \
\... add address=222.124.64.0/21 list="nice"
address ranges may not overlap

dimana 222.124.64.0/21 adalah supernet dari 222.124.64.0/23 artinya diantara dua blok ip tersebut saling overlap, sehingga pada saat proses import menggunakan file .rsc akan selalu berhenti pada saat menemui situasi seperti ini.

Sampai saat ini saya belum menemukan cara yang praktis utk mengatasi hal tersebut diatas.
Kalau saja kita bisa membuat address-list dari table prefix BGP yang dijalankan di mikrotik maka kita bisa mendapatkan address-list dengan lebih sempurna.

 

Selanjutnya pada /ip firewall mangle perlu dilakukan konfigurasi sbb:

/ ip firewall mangle
add chain=forward src-address-list=nice action=mark-connection \
    new-connection-mark=mark-con-indonesia passthrough=yes comment="mark all \
    indonesia source connection traffic" disabled=no
add chain=forward dst-address-list=nice action=mark-connection \
    new-connection-mark=mark-con-indonesia passthrough=yes comment="mark all \
    indonesia destination connection traffic" disabled=no
add chain=forward src-address-list=!nice action=mark-connection \
    new-connection-mark=mark-con-overseas passthrough=yes comment="mark all \
    overseas source connection traffic" disabled=no
add chain=forward dst-address-list=!nice action=mark-connection \
    new-connection-mark=mark-con-overseas passthrough=yes comment="mark all \
    overseas destination connection traffic" disabled=no
add chain=prerouting connection-mark=mark-con-indonesia action=mark-packet \
    new-packet-mark=indonesia passthrough=yes comment="mark all indonesia \
    traffic" disabled=no
add chain=prerouting connection-mark=mark-con-overseas action=mark-packet \
    new-packet-mark=overseas passthrough=yes comment="mark all overseas \
    traffic" disabled=no


Langkah selanjutnya adalah mengatur bandwidth melalui queue simple, untuk mengatur bandwidth internasional 128Kbps dan bandwidth lokal IIX 256Kbps pada komputer dengan IP 192.168.2.4 dapat dilakukan dengan contoh script sbb:

/ queue simple
add name="harijant-indonesia" target-addresses=192.168.2.4/32 \
    dst-address=0.0.0.0/0 interface=all parent=none packet-marks=indonesia \
    direction=both priority=8 queue=default/default limit-at=0/0 \
    max-limit=256000/256000 total-queue=default disabled=no
add name="harijanto-overseas" target-addresses=192.168.2.4/32 \
    dst-address=0.0.0.0/0 interface=all parent=none packet-marks=overseas \
    direction=both priority=8 queue=default/default limit-at=0/0 \
    max-limit=128000/128000 total-queue=default disabled=no


Script diatas berarti hanya komputer dengan IP 192.168.2.4 saja yang di batasi bandwidthnya 128Kbps internasional (overseas) dan 256Kbps lokal IIX (indonesia) sedangkan yang lainnya tidak dibatasi.

Hasil dari script tersebut adalah sbb:
 

Image

Gambar 3. simple queue untuk komputer 192.168.2.4


Dengan demikian maka komputer 192.168.2.4 hanya dapat mendownload atau mengupload sebesar 128Kbps untuk internasional dan 256Kbps untuk lokal IIX.

Untuk mengujinya dapat menggunakan bandwidthmeter sbb:

 

Image 

Gambar 4. Hasil bandwidth meter komputer 192.168.2.4 ke lokal ISP

 

Image 

Gambar 5. Hasil bandwidth meter ke ISP internasional

Dengan demikian berarti Mikrotik telah berhasil mengatur pemakaian bandwidth internasional dan lokal IIX sesuai dengan yang diharapkan pada komputer 192.168.2.4.

Pada penjelasan versi-3 ini proses mangle terhadap traffic “overseas” dapat lebih akurat karena menggunakan address-list dimana arti dari src-address=!nice adalah source address “bukan nice”  dan dst-address=!nice adalah destination address “bukan nice”.

Sehingga demikian traffic “overseas” tidak akan salah identifikasi, sebelumnya pada penjelasan versi-2 traffic “overseas” bisa salah indentifikasi karena traffic “overseas” di definisikan sbb

add connection-mark=mark-con-indonesia action=mark-packet new-packet-mark=indonesia chain=prerouting comment="mark indonesia"
add packet-mark=!indonesia action=mark-packet new-packet-mark=overseas chain=prerouting comment="mark all overseas traffic"

packet-mark=!indonesia artinya “packet-mark=bukan paket Indonesia”, padahal “bukan paket Indonesia” bisa saja paket lainnya yang telah didefinisikan sebelumnya sehingga dapat menimbulkan salah identifikasi.

Adapun teknik diatas  telah di test pada  router  mikrotik yang menjalankan NAT , jika router mikrotik tidak menjalankan NAT coba rubah chain=prerouting menjadi chain=forward.

Untuk lebih lanjut mengenai pengaturan bandwidth pada Mikrotik dapat dilihat pada manual mikrotik yang dapat didownload pada

http://www.mikrotik.com/docs/ros/2.9/RouterOS_Reference_Manual_v2.9.pdf


Script diatas dapat diimplementasikan pada Mikrotik Versi 2.9.27 , untuk versi mikrotik sebelumnya kemungkinan ada perbedaan perintah.

Reference:


    * http://www.mikrotik.com
    * http://www.mikrotik.co.id
    * http://wiki.mikrotik.com

 

Selamat mencoba.






Last Updated ( Wednesday, 08 November 2006 )

Tuesday, October 03, 2006

kompres pake tar dan gz .. sok hiap wae

Unix file compression utilities:



There are two commonly used free file compression utlities that you will find in wide use on the internet.



tar - tape archive



This utility basically appends a list of files &/or directories into one flat file. This was commonly used in the early days of Unix when writing large amounts of information to a tape.

Creating a tape archive:



tar -cf archive.tar myDirectories/



Note - using the "v" flag prints out extra messages, as verbose mode, though it's not related to extracting files.

Listing the contents of an archive:



tar -tf archive.tar



It is generally a good idea to preview the contents of tape archives before unpacking them. This can become a serious problem if you are currently root, and the archive just happens to jump out of the current directory, and write over some important system files.

Extracting all files from an archive:



tar -xf archive.tar



To extract just partial pieces from the archive, supply a file or directory name after the archive name. You can list as many as desiered here, separated by spaces.



tar -xf archive.tar filename



gzip - gnu zip



This is a gnu utility that is used to compress/decompress a file. Generally, if there is a set of files to compress, they will be sent through tar first to create a single file.

Compress:



gzip archive.tar

Decompress:



gunzip archive.tar.gz

Merged filenames:



Sometimes, you will download files ending with the extension *.tgz - these are essentially identical to files ending with *.tar.gz files. You can gunzip them, and untar them just the same way. If you're working with a recent version of gnu tar, you may be able to take a shortcut, as described below.



Merging commands



The "z" flag works with gzip, to either create a tar/gzipped archive:



tar -czvf archive.tgz files/



...or decompress a tar/gzipped archive:



tar -xzvf archive.tgz



tar to a pipe



If you're concerned with filling your disk during a tar, or with filling a disk cache, you can also tar to a pipe, which doesn't write the compressed file to disk, but instead just stores it temporarily in memory.



tar -cf - ./filename | (cd other-directory; tar -xf -)

 

Thursday, July 06, 2006

sekilas tentang mikrotik kebanggaanku

Alhamdulillah akhirnya aku menemukan bw manager yang selama ini aku cari.

Awalnya aku pake ipfw untuk limiting bandwidth .. bagus sech hanya statik.
Maksudnya apabila kita membatasi client A = rx=32kbps , tx=16kbps. maka si client A hanya bisa mendapatkan kemampuan maximal = 32kbps ( 32/8 = 4kbyte / second)

jadi dia gak punya akselerai buat menaikan kecepatan jika kondisi network kita kosong. khan sayang yah. hanya saja system ipfw bagus untuk anda yang clientnya di patuk tanpa di kasi kesempatan untuk bisa brust.

brustable artinya jika client A=rx32kbps, tx=16kbps, brust=64kbps itu artinya sewaktu waktu jika jaringan kosong si client A bisa dan mampu naik kemampuannya sampe ke 64kbps, hanya jika kondisi network full kemba;i, si A akan mendapatkan minimum bw 32 Kbps. menarik khan


hasil uji coba ku membandingkan antara kondisi ipfw yang statik denga brust. emang menjadi terasa beda ngan brustable

salahsatu program yang saya pake untuk brustable di linux adalah HTB. ( ingat usahakan di slackware, untuk mendapatkan kemampuan maximal dari HTB) dimana HTB ini GPL packet dan mempunyai keampuan yang huebat bener .. hanya saja confogurasi nya agak rumit harus membutuhkan ke sabaran... ( pasti anda di sayang tuhan ... khan orang sabar di sayang tuhan) .

hanya satu hal g membuat saya bahagia saya mendapatkan program mikrotik , dimana
MikroTik RouterOS™ adalah sistem operasi dan perangkat lunak yang dapat digunakan untuk menjadikan komputer manjadi router network yang handal, mencakup berbagai fitur yang dibuat untuk ip network dan jaringan wireless, cocok digunakan oleh ISP dan provider hostspot.

so keren khan kita bisa lakukan dan membuat jaringan kita berjalan dengan baik dengan kemampuan mikrotik ini seperti :

  1. Firewall and NAT - stateful packet filtering; Peer-to-Peer protocol filtering; source and
  2. destination NAT; classification by source MAC, IP addresses, ports, protocols, protocol options, interfaces, internal marks, content, matching frequency
  3. Routing - Static routing; Equal cost multi-path routing; Policy based routing (classification by source and destination addresses and/or by firewall mark); RIP v1 / v2, OSPF v2, BGP v4
  4. Data Rate Management - per IP / protocol / subnet / port / firewall mark; HTB, PCQ, RED, SFQ, byte limited queue, packet limited queue; hierarchical limitation, CIR, MIR, contention ratios, dynamic client rate equalizing (PCQ)
  5. HotSpot - HotSpot Gateway with RADIUS authentication/accounting; data rate limitation; traffic quota; real-time status information; walled-garden; customized HTML login pages; iPass support; SSL secure authentication
  6. Point-to-Point tunneling protocols - PPTP, PPPoE and L2TP Access Concentrators and clients; PAP, CHAP, MSCHAPv1 and MSCHAPv2 authentication protocols; RADIUS authentication and accounting; MPPE encryption; compression for PPPoE; data rate limitation; PPPoE dial on demand
  7. Simple tunnels - IPIP tunnels, EoIP (Ethernet over IP)
  8. IPsec - IP security AH and ESP protocols; Diffie-Hellman groups 1,2,5; MD5 and SHA1 hashing algorithms; DES, 3DES, AES-128, AES-192, AES-256 encryption algorithms; Perfect Forwarding Secresy (PFS) groups 1,2,5
  9. Web proxy - FTP, HTTP and HTTPS caching proxy server; transparent HTTP caching proxy; SOCKS protocol support; support for caching on a separate drive; access control lists; caching lists; parent proxy support
  10. Caching DNS client - name resolving for local use; Dynamic DNS Client; local DNS cache with static entries
  11. DHCP - DHCP server per interface; DHCP relay; DHCP client; multiple DHCP networks; static and dynamic DHCP leases
  12. Universal Client - Transparent address translation not depending on the client's setup
  13. VRRP - VRRP protocol for high availability
  14. UPnP - Universal Plug-and-Play support
  15. NTP - Network Time Protocol server and client; synchronization with GPS system
  16. Monitoring/Accounting - IP traffic accounting, firewall actions logging
  17. SNMP - read-only access
  18. M3P - MikroTik Packet Packer Protocol for Wireless links and Ethernet
  19. MNDP - MikroTik Neighbor Discovery Protocol; also supports Cisco Discovery Protocol (CDP)
  20. Tools - ping; traceroute; bandwidth test; ping flood; telnet; SSH; packet sniffer Layer 2 connectivity
  21. Wireless - IEEE802.11a/b/g wireless client and Access Point; Wireless Distribution System (WDS) support; virtual AP; 40 and 104 bit WEP; access control list; authentication on RADIUS server; roaming (for wireless client); Access Point bridging
  22. Bridge - spanning tree protocol; multiple bridge interfaces; bridge firewalling
  23. VLAN - IEEE802.1q Virtual LAN support on Ethernet and WLAN links; multiple VLANs; VLAN bridging
  24. Synchronous - V.35, V.24, E1/T1, X.21, DS3 (T3) media types; sync-PPP, Cisco HDLC, Frame Relay line protocols; ANSI-617d (ANDI or annex D) and Q933a (CCITT or annex A) Frame Relay LMI types
  25. Asynchronous - serial PPP dial-in / dial-out; PAP, CHAP, MSCHAPv1 and MSCHAPv2 authentication protocols; RADIUS authentication and accounting; onboard serial ports; modem pool with up to 128 ports; dial on demand
  26. ISDN - ISDN dial-in / dial-out; PAP, CHAP, MSCHAPv1 and MSCHAPv2 authentication protocols; RADIUS authentication and accounting; 128K bundle support; Cisco HDLC, x75i, x75ui, x75bui line protocols; dial on demand
  27. SDSL - Single-line DSL support; line termination and network termination modes Hardware requirements
  28. CPU and motherboard - advanced 4th generation (core frequency 100MHz or more), 5th generation (Intel Pentium, Cyrix 6X86, AMD K5 or comparable) or newer uniprocessor Intel IA-32 (i386) compatible (multiple processors are not supported)
    RAM - minimum 48 MB, maximum 1 GB; 64 MB or more recommended
    Hard Drive/Flash - standard ATA interface controller and drive (SCSI and USB controllers and drives are not supported; RAID controllers that require additional drivers are not supported) with minimum of 64 MB space Hardware needed for installation time only Depending on installation method chosen the router must have the following hardware:
    Floppy-based installation - standard AT floppy controller and 3.5'' disk drive connected as the first floppy disk drive (A); AT, PS/2 or USB keyboard; VGA-compatible video controller card and monitor
    CD-based installation - standard ATA/ATAPI interface controller and CD drive supporting "El Torito" bootable CDs (you might need also to check if the router's BIOS supports booting from this type of media); AT, PS/2 or USB keyboard; VGA-compatible video controller card and monitor
    Floppy-based network installation - standard AT floppy controller and 3.5'' disk drive connected as the first floppy disk drive (A); PCI Ethernet network interface card supported by MikroTik RouterOS (see the Device Driver List for the list)
    Full network-based installation - PCI Ethernet network interface card supported by MikroTik RouterOS (see the Device Driver List for the list) with PXE or EtherBoot extension booting ROM (you might need also to check if the router's BIOS supports booting from network) Configuration possibilities RouterOS provides powerful command-line configuration interface. You can also manage the router through WinBox - the easy-to-use remote configuration GUI for Windows -, which provides all the benefits of the command-line interface, without the actual "command-line", which may scare novice users. Major features:
    Clean and consistent user interface
    Runtime configuration and monitoring
    Multiple connections
    User policies
    Action history, undo/redo actions
    safe mode operation
    Scripts can be scheduled for executing at certain times, periodically, or on events. All command-line commands are supported in scripts When router is not configured, there are only two ways to configure it:
  29. Local terminal console - AT, PS/2 or USB keyboard and VGA-compatible video controller card with monitor
  30. Serial console - First RS232 asynchronous serial port (usually, onboard port marked as COM1), which is by default set to 9600bit/s, 8 data bits, 1 stop bit, no parity After the router is configured, it may be managed through the following interfaces:
  31. Local teminal console - AT, PS/2 or USB keyboard and VGA-compatible video controller card with monitor
  32. Serial console - any (you may choose any one; the first, also known as COM1, is used by default) RS232 asynchronous serial port, which is by default set to 9600bit/s, 8 data bits, 1 stop bit, no parity
  33. Telnet - telnet server is running on 23 TCP port by default
  34. SSH - SSH (secure shell) server is running on 22 TCP port by default (available only if security package is installed)
  35. MAC Telnet - MikroTik MAC Telnet potocol server is by default enabled on all Ethernet-like interfaces
  36. Winbox - Winbox is a RouterOS remote administration GUI for Windows, that use 3986 TCP port (or 3987 if security package is installed)

webmail dengan qmail secara cepat

Berminggu minggu sampe belel mata koe .. dengan target harus menyelasikan server pake debian ( so yang aneh susah banget ref nya ) qmailku hanya bisa berjalan jika menggunakan kernel 2.2 tp kalo 2.4 heheh baru nyoba .... eeeee tengah jalan ketemu sama si http://www.qmailrock.com gile dia ngasi program webserver komplit plus howto install . hmm lumayan juga nech kalo gw coba eee... akhirnya berhasil ..

ini yang ada dan dilakukan d qmail rocks

Part 1 - Download All the Needed Items for the Qmail installation
Part 2 - Installing Qmail itself
Part 3- Installing EZmlm and EZmlm-idx
Part 4- Installing Autoresponder
Part 5- Installing Vpopmail
Part 6- Installing VQadmin
Part 7- Installing maildrop
Part 8- Installing QmailAdmin
Part 9 - Finalizing the qmail installation
Part 10 - Uninstalling Sendmail/Postfix
Part 11 - Starting up qmail
Part 12 - Installing Courier-imap/imaps with Courierpassd
Part 13 - Installation of the Squirrelmail web mail program
Part 14 - Clam Anti Virus & SpamAssassin
Part 15 - Installing qmail-scanner w/qms-analog
Part 16 - Installing Qmailanalog & Qlogtools
Part 17 - Installing Qtrap
Part 18 - Maintaining your qmail server

WOW ..... Komplit khan ... gile .. gw salut dah sama si Eric Siegel
thank's man .. ...

so guys .. dont hilap use qmailrocks